Installed 3rdRail (from CodeGear) a few days ago, and whenever i try to run gem, i get the following error:
/usr/local/lib/ruby/1.8/i686-linux/digest/md5.so: libcrypto.so.4 : cannot open shared object file: No such file or directory
The only google article i could find about it was in japanese (google translate rocks – http://rihi.cocolog-nifty.com/blog/2007/09/3rdrail_ubuntu__7fd4.html) and (i think) he suggested running the following command:
# Ln – sf / usr/lib/libcrypto.so.0.9.8 / usr/lib/libcrypto.so.4
which indicates to me that there is a difference between Fedora Core 7 (which 3rdRail is approved and tested against) and Ubuntu Gutsy (which i’m running).
EIther way running the command above resolved all the problems and gem continued to function as expected….Too bad the 3rdRail documentation is also quite poor – not a great start :(